DedeCMS完美实现在PHP5.4上运行

网站技术 qyuef 9年前 (2012-10-24) 179次浏览 4个评论

在Ubuntu Server 12.10中测试安装DedeCMS,发现Ubuntu中默认集成的是PHP5.4.6版本了,在安装DedeCMS过程中发现两个小问题:

1.系统默认没有GD库;

2.程序无法正常登录;

我们只需要简单的两个步骤即可实现Ubuntu Server 12.10中完美运行DedeCMS 5.7SP1



安装PHP的GD库,在终端中输入:

sudo apt-get install php5-gd

确定后系统就完成安装。



无法正常登录,将下面代码粘贴到/include/helpers/util.helper.php中:

 

// Fix for removed Session functions 

function fix_session_register(){ 

    function session_register(){ 

        $args = func_get_args(); 

        foreach ($args as $key){ 

            $_SESSION[$key]=$GLOBALS[$key]; 

        } 

    } 

    function session_is_registered($key){ 

        return isset($_SESSION[$key]); 

    } 

    function session_unregister($key){ 

        unset($_SESSION[$key]); 

    } 

} 

if (!function_exists('session_register')) fix_session_register();

这样,就可以让DedeCMS在PHP5.4环境中运行了。

喜欢 (1)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(4)个小伙伴在吐槽
  1. 很强大,学习中,,继续关注!
    PBT2012-10-25 13:16 回复
  2. 看不懂啊。有没有简单的教程呢?
    剪板机刀片2012-10-25 21:25 回复
  3. 看不懂啊。有没有简单的教程呢?
    折弯机模具2012-10-29 22:15 回复
  4. 看不懂啊!感觉好复杂的样子
    北京网站设计2015-08-12 14:11 回复